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Working with MapInfo and QGIS

1. Background
In March 2017, CLASP made the formal decision to migrate its GIS-based software work from
MapInfo to QGIS. This decision was taken because:

 CLASP’s existing copies of the MapInfo software were many years out of date, and updating
them would have involved major expense.

 A review by CLASP1 of current geomatics policy among leading government archaeological
bodies (including ADS York and the county HER network) and leading commercial
archaeological companies (including Cotswold Archaeology, Wessex Archaeology, ULAS and
Oxford Archaeology) showed that all these bodies have now standardised on the use of ESRI
ArcGIS (which creates “Shapefiles” as its standard file-format) rather than MapInfo (which
creates “TAB” files as its standard file-format).

 QGIS is open source freeware, providing a powerful GIS toolkit with very similar features to
MapInfo and ArcGIS. In particular, it is designed to interoperate very easily with ArcGIS. It
may be downloaded from http://www.qgis.org/en/site/, and used without payment or
obligation. The current version is 2.1.18, as of March 2017 (NB: this version is not
compatible with Windows XP – if you are still running WinXP, you should use QGIS v1.8.0).

 QGIS is therefore a zero-cost option for CLASP, which will provide easy compatibility with
ADS/HER and with professional archaeological companies with whom we may wish to work
in the future.

2. Purpose of this document
This document is NOT intended as a teaching manual for QGIS – there are plenty of online sources
(such as YouTube, and the official QGIS website http://www.qgis.org) where dozens of QGIS
teaching videos can be accessed and studied, and CLASP members are strongly recommended to
explore such online sources for themselves.

This document simply describes how to carry out a few basic common tasks in QGIS, and also
explains how to shift files between MapInfo and QGIS. Some knowledge of MapInfo is assumed;
however, where relevant, explanations of MapInfo operations are given.

It is not claimed that the following list of tasks is exhaustive, or that it will answer every question
posed by new users.

In the longer term, CLASP is also exploring the possibility of obtaining professional instruction in
the use of QGIS, to be given to a small core group of interested members.

3. Transferring an existing MapInfo file from MapInfo to QGIS
An entire MapInfo native project file can be imported directly into QGIS in a single operation – but if
it is done in this way, all the individual layers in the MapInfo file will be combined into a single layer
in QGIS, with no colour distinction, and they cannot be separated again. This is obviously
undesirable.

Therefore, to maintain the separate layers in the original MapInfo file, you should export each layer
from MapInfo separately, one at a time, and then import them one by one into QGIS.

Using this method, for example, CLASP’s existing OS MasterMap dataset can be transferred into
QGIS, to provide a basic reference frame for any project-specific work in QGIS.

                                                          
1 See CLASP Procedural Instruction PI06 “GIS systems – plotting the way ahead for CLASP”
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Step 1: Export the layers individually from MapInfo:
 Open the required table (*.TAB file) in MapInfo.
 Open a browser window (menu commands Window>New Browser Window, or just

press F2) and then select "Clasp_Topographic_2013" from the dropdown list offered.
 Use Query>Select, then build a query to select the sub-group of features that you want:
 (eg all records in "Clasp_Topographic_2013" for which DescriptiveGroup = "Road Or Track").
 Run the query – the results will be displayed in the browser as a new Table. Then save the

result, using File>Save As… and selecting the Table that you have just created – when
prompted for a name, enter the filename under which you want to save it. In the example
above, you could save it as "Clasp_Topo_Roads.TAB"

 Continue to run queries and save the resulting tables, until you have saved ALL the
DescriptiveGroup categories in the original MapInfo file. For example, in the file
"Clasp_Topographic_2013", there are 9 DescriptiveGroup categories:

Building
Inland Water
Road or Track
Path
Rail
Landform (this has sub-categories, save each of them in turn)
General Feature (ditto)
General Surface (ditto)
Network or Polygon Closing Geometry (ditto)

Step 2: Import the individual saved layers into QGIS:
 Open a New Project in QGIS, and save it, e.g. as "QGIS test project"
 Now use the command Add Vector Layer to add each MasterMap layer that you saved

from MapInfo in Step 1, browsing to locate each file in turn.
 Re-save the project at regular intervals.

4. Adding new survey data into QGIS (and MapInfo, where relevant)
OK, you’ve loaded the OS MasterMap data into QGIS, which gives you a basic OS reference frame,
upon which to add your project-specific data. Now, how do you add your own project-specific data?

 Important Note: Like MapInfo, QGIS does not make copies of the raster and vector files that
you load into it – instead, QGIS remembers the location of all these files. Hence, before you
start loading any vector or raster files into QGIS, you should take the time to copy all the
files that you will want into suitable sub-folders of the folder in which you are storing your
project master file, otherwise you will certainly get into trouble later on, by accidentally
deleting or moving files that are used in your project.  Get into the habit of organising your
project files in this way every time, it will save you a lot of heartache!

4.1 Placing a raster graphic file accurately into a layer in QGIS
Raster graphics can include such items as images of early maps, magnetometer plots, aerial
photographs, hand-drawn sketches and diagrams of parts of a site, etc. These are all things that you
might want to include in your QGIS project map.

How to do it:
 First select and import the required graphic file, using the button Add Raster Layer and

browsing to find the file that you want. This is easy.
 Now you need the imported graphic to display in the correct location on the map, and at

correct magnification. The imported graphic must be georeferenced*.
(* In plain English, this simply means “identify some key points on your graphic, and give
them accurate OS mapping references that QGIS can understand”.)
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First ensure that you have selected the required raster layer in the Layers display box. Then there
are two ways to georeference it:

 Using the menu option Raster>Georeferencer
 Using the menu option Settings>Custom CRS

The second of these methods uses only 2 georeference points and it is perfectly OK – but the first
method above is more flexible, easier to use, and more accurate, as it allows you to define any
number of georeference points on your selected raster graphic. This method is described below:

 In GQIS, select menu command Raster>Georeferencer>Georeferencer. This opens a
screen in which you select a graphic image by browsing to find the image file you want to
import (Caution: ensure image file is aligned with North at the top before you import it!)

 Now assign OS grid co-ordinates to selected points in the chosen graphic image, as follows:
 Select Edit>Add point, and then choose the option to use the pen tool to add a point

from the map canvas* on to the graphic image. (*assuming that you have the appropriate
MasterMap data already available and loaded into QGIS)

 Repeat this several times, adding further points. HINT: Choose points on the image that can
easily be located on the map, such as road junctions, points on buildings, field corners etc.

 When you have marked sufficient points, select from the Georeferencer sub-menu (i.e. the
sub-menu in the panel halfway down your screen, in which the imported graphic is still
located) the option Settings>Transformation Settings, enter a meaningful name for
the output raster file that will appear in your project when it is imported, and then just
press OK, there’s no need to fiddle with the other settings.

 Now the raster file will appear in the correct location on the QGIS map. You can edit its
attributes – for example, adjust the transparency to (say) 50% so that other layers can be
seen through the raster image layer that you have just added.

 It is not practical to import and locate a raster file that is NOT aligned with north at the top.
QGIS and MapInfo do not import the image itself and store it in the project file – they just
import a reference to where the image file is located on the computer. So, if you try to
rotate the image when it is imported into MapInfo or QGIS, this can cause huge computing
problems because the original graphic file is not contained in the project file. Thus, ideally
you should rotate and realign the graphic file first (e.g. in PaintShop Pro or PhotoShop), so it
is correctly aligned NS – it's a pain, but it is the easiest and most professional solution.

4.2 Placing a raster graphic file accurately into a layer in MapInfo
This is broadly very similar to importing a raster graphic into QGIS as described in 2.1, so for the
sake of completeness we will summarise the procedure here:

 First obtain the GPS data for several points on your chosen graphic image, e.g. from Google
Earth (or from QGIS if your chosen image is already loaded into QGIS).

 You must convert any co-ordinates that you get from Google Earth, because they will be in
degrees of Lat/Long, and QGIS/MapInfo use OS grid co-ordinates. There is a co-ordinate
conversion tool at
 http://www.bgs.ac.uk/data/webservices/convertForm.cfm

 Now open the project in MapInfo to which you want to import your graphic.
 Open File > Table, and select files of Raster Image type.
 Browse and select the chosen raster image file.
 A tick box now appears, offering a choice of Display or Register – select Register.
 You will now see a picture of the selected image file, with various editing options.
 First select the required Projection type: this will normally be: British Co-ordinate

Systems > British National Grid, OS1936
 Now select 4 or more points (e.g. the four corners of the image) and assign to these the GPS

co-ordinates that you have already obtained for the image.
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 Then press OK, and the image will be registered and displayed

4.3 Loading OS maps into QGIS and MapInfo
OS provides free downloads of its “Street View” maps for the entire UK, including high-res maps in
TIFF raster format. These are just simple road maps with no topographic information, but they are
better than nothing and can be useful “background” maps to establish a precise base for adding
other details, once they have been imported into QGIS and georeferenced.

Alternatively, you can import scans that you have made from any OS map, or screen-grabs from
Google Earth, into QGIS (or MapInfo), just as described in 4.1 and 4.2. (Bear in mind, however, that
OS imposes copyright limitations on its maps, and though you can use this procedure for your own
research you are not authorised to use scans of their maps in published work etc.)

 Note 1: Once a raster image map has been georeferenced in MapInfo, it can be loaded
directly into QGIS without any further need of georeferencing, since the required .TAB file
for the image file has already been created by MapInfo and it will work equally well in QGIS.

 Note 2: The reverse of this operation – i.e. loading into MapInfo a raster image map that
has already been georeferenced in QGIS – will NOT succeed, unless you first do some
further work. This is because QGIS does not create a *.TAB file for the georeferenced points;
instead it creates a *.points file, which MapInfo cannot read. If you want to transfer into
MapInfo a file that has been georeferenced in QGIS, you should first re-save it in ESRI
Shapefile format (see Section 5.1 below) – then it can be exported to MapInfo (for versions
of MapInfo up to v6, use MapInfo’s Universal Translator tool to import the ERSI shapefile;
for v8 of MapInfo and later, direct import of ESRI shapefiles is incorporated in the program).

4.4 Loading Excel file data into QGIS (eg a plot of finds/locations)
This must be done by adding a new “delimited text” layer. There are “how-to-do” instructions for
this online at:

 http://maps.cga.harvard.edu/qgis/wkshop/import_csv.php
 http://www.qgistutorials.com/docs/importing_spreadsheets_csv.html

Excel files must first be converted into CSV (comma-separated variable) format.

4.5 Loading data from an Excel file into MapInfo
There are two ways of doing this, and neither requires conversion of the data format, the native MS
Excel data format can be imported directly:

a) A complete spreadsheet, or a page or section of a spreadsheet, can be imported direct into
MapInfo via menu options File>Open Table, then select File Type as "Microsoft Excel", then
select the desired directory and file, then follow on-screen prompts to select the relevant part of
the chosen file (entire spreadsheet, a selected page, or specified range of cells). However, this type
of import does not allow the table to be edited after it has been imported, so it is limited.

b) A better approach is to start by creating a new table, and then copying and pasting data into it.
Use the menu options File>New Table, then select "open new browser window" not "open new
mapper window"; next, add fields one by one to define the New Table Structure (you can edit the
structure later via menu options Table>Maintenance>Table Structure); then you can simply
use cut and paste to fill the new empty table with data. In MS Excel, select the required range of
cells from the source spreadsheet (NB: do not include any header cells in your selection); now use
CTRL+C to copy your selection; then enter MapInfo, select the new empty table that you have just
created, and use CTRL+V to paste the selected MS Excel data into the new table.
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With this method of data import, the table and its data can be edited or modified after it has been
imported.

If you intend to display the imported data on a map, the imported data table must include columns
for the Easting and Northing of each line of data in the table.

4.6 Loading a *.kml2 file into QGIS (eg, as used with Google Earth)
KML files are used by many hand-held GPS units, and are also supported by Google Earth and all the
major GIS software tools. They provide a simple means of defining a vector path (for example, by
creating a set of linked points using a GPS handheld device whilst walking across the landscape; or
by drawing a route onto the display in Google Earth and saving the route data in KML format). KML
files are very small, and are transferable between different applications – for instance, a field
worker might define a path based on work in the field using a handheld GPS unit, then email the
resulting KML file to a colleague in the office, who can open the KML file in QGIS or Google Earth
and see the field-worker’s route displayed on the map.

4.7 Generating a Garmin Map File (*.kmz3) from QGIS
It is possible to use QGIS to create maps that can be downloaded and used in a standard Garmin
GPS handset. To do this, you need to be using QGIS v2.0.0 or later (which requires Windows 7 or
later), and you will also need to download and install the small plug-in ‘GarminCustomMaps’ from
the QGIS plug-ins official website (http://plugins.qgis.org/plugins/).

The method for creating such maps, together with the results of an experimental assessment of the
practical accuracy and usefulness of such a method, is described in Appendix A.

The resulting maps work in any Garmin GPS device; they also work directly in Google Earth. This
method provides a simple and cheap way to find approximate locations for objects that have
already been recorded in MapInfo or QGIS – and so long as high accuracy (e.g. better than the
nearest 5m) is not essential, it may be regarded as a useful fieldwork tool.

5. Exporting a QGIS project or layer file back from QGIS into MapInfo
Complete project files, or individual layers from a project file, can be exported back into MapInfo in
the form of ESRI Shapefiles (MapInfo v8 and later, use Universal Translator Tool to import into v6).

5.1 Saving a QGIS layer in ESRI Shapefile format
In many cases, the layers that you create in QGIS will have been copied into QGIS from original
MapInfo data-files in *.TAB format.

A *.TAB-format layer in QGIS can be saved in ESRI Shapefile format as follows:
 Open the Layers Panel, and select the TAB-file layer that you want to save in Shapefile

format.
 Select menu option Layer>Save As
 In the pop-up form that opens, select the file-format to be saved as “ESRI Shapefile”, and

choose a filename and directory location for it, then press OK. If you have also opted to add
the new shapefile to the map (by selecting the appropriate tick-box on the pop-up form), it
will now appear in the Layers Panel.

                                                          
2 Keyhole Markup Language
3 A proprietary version of KML used by Garmin GPS software products
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Example:
Conversion of a typical set of MapInfo TAB-format files:

HPL2_02_FW_Stone_Scatter.DAT
HPL2_02_FW_Stone_Scatter.ID
HPL2_02_FW_Stone_Scatter.IND
HPL2_02_FW_Stone_Scatter.MAP

The following output Shapefiles are created:
HPL2_02_FW_Stone_Scatter.dbf
HPL2_02_FW_Stone_Scatter.prj
HPL2_02_FW_Stone_Scatter.qpj
HPL2_02_FW_Stone_Scatter.shp
HPL2_02_FW_Stone_Scatter.shx

The shapefile data can now be exported into MapInfo (see also 4.3 above).

6. Operations in QGIS involving databases

6.1 Saving imported TAB layer with database information, in Spacialite form
In order to be able to carry out SQL-like queries on the database content of an imported TAB layer,
using the Database Manager option, the layer in question must first be saved as a QGIS Spacialite
layer (because QGIS only allows DBM queries on Spacialite layers).

 Select the TAB layer in question.
 Select menu option Save As, select the file-format option “ESRI Shapefile”, and choose

a suitable filename and directory for the resulting file.  Also select the option “Add saved
file to map”, and it will also appear as one of the displayed layers.

NB: This procedure is only necessary if you want to carry out advanced searches using the Database
Manager DBM.  Ordinary searches can be built up simply from the standard options included in the
Attribute Table, see items 6.2 and 6.3 below.

6.2 Running simple queries on a database layer
However, simple queries can be run without needing to use the Database Manager option – and
therefore without needing to save a layer in Spacialite format:

 Right-click on the layer in question, and select “Open attribute table”
 The database for this layer will now open in a pop-up form
 Queries can be run (in QGIS v2.1.14) by selecting the icon shaped like a Greek letter epsilon

(“Select features using an expression”).
 Click on the option “Fields and values” – this expands to show a list of all the available fields

in the database.
 Double-click on the field that you wish to query; then select the option “Load values – all

unique”.  Double-click the “=” sign, and then double-click the unique value on which you
wish to search.

 Press OK, and the search will be performed – the results are highlighted in the table, and
also displayed visually on the map display.

6.3 Saving the results of a query as a separate new vector layer
Once the search has been carried out, the results can be saved as follows:

 Select menu option Layer > Save selection as vector file
 Select the file format as ESRI Shapefile, and enter a suitable filename and directory.
 The search result will be saved as a new Shapefile – and if you also selected the option

“Add saved file to map” it will also appear as one of the displayed layers.
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6.4 Enhancing the visual display of database data, by use of graded colours
A display of database information (for example, the spatial distribution of an assemblage of coins
from a metal-detection survey) can be made much more informative by utilising some of the
commands in the Layer>Properties option of QGIS.

The first illustration shows the map browser display of just such a database. The coins are shown in
their correct positions – but all coins are shown in the same colour, and this gives no information
about variations in other parameters, such as the date of issue of the coins.

The inset image (produced by right-clicking
on the selected layer and choosing the
Properties option, and then the Style
tab) shows that the standard default
settings have been adopted for displaying
this coin data.
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To improve the quality of the
display, we can select options as
shown in the next image below:

 The ‘Symbol’ option at
the top of the screen has
been changed from
‘Single symbol’ to
‘Categorised’

 The ‘Column field has
been changed (via its
drop-down sub-menu) to
select the ‘Date’ field
from the database as the
control variable for
determining the displayed
colour of the symbols.

 The symbol colour has been changed from plain yellow to Color Ramp > YlOrRd
 By pressing the ‘Classify’ button, a list of all the different database values for ‘Date’ is

displayed, and the colours are now graduated – from yellow for the earliest coins through
to deep red for the latest coins in the sample.

The result of these changes is shown in the updated display below:

The display is now much more informative – we can see at a glance, for instance, that there is a
concentration of later-period coins around the main road and in the NW sector of the camp.
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7. Miscellaneous hints and tips

7.1 Cleaning unwanted colours from the display of raster layers
Very often, when a raster graphic (such as a geophysics plot, or an overhead photograph screen-
grabbed from Google Earth) is imported into QGIS, unwanted elements will also be displayed (e.g.
black wedges around the edges of the photo image, white backgrounds of the geophysics plot which
overlay and obscure the landscape beneath). This can be very distracting.

Such unwanted colours can easily be removed from the QGIS display, as follows:
 Select the QGIS layer in question, and right-click on it.
 Select the Properties sub-menu.
 From the pop-up form that now opens, choose the Transparency tab.
 In the part of the form labelled “Custom transparency options” you will see a row of 4

icons – the second icon from the left is labelled “Add values from display”, and when
you click on it, the cursor changes to a set of crosshairs.

 If you now place these crosshairs over one of the colours that you want to eliminate from
the display and left-click, the value of that colour will be added to the list of transparent
pixels – and when you press OK at the bottom of the form, the colour that you have chosen
will be suppressed from the screen display.

 You can add as many further colours as you want to this list, by repeating the above steps.
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Appendix A: Using QGIS v2.0.1 with ‘GarminCustomMaps’ plug-in

1. Introduction
Trials were carried out, using QGIS v2.0.1 to create maps for direct use in a Garmin-powered GPS
handset. The aim was to evaluate the practicality of this method for use in the field.

Method:
 The geophysics results for Barby Hill (in the form of a JPG screen-grab from the CorelDraw

master-map, correctly aligned with the National Grid) were loaded into QGIS v2.0.1 and
georeferenced so as to position the image accurately w.r.t. the National Grid in QGIS.

 A number of experimental Garmin sample maps were created, using the QGIS plug-in
GarminCustomMaps, and with various different settings of the available variables.

2. Experimental results
Filename Size (Mb) Set tiles Set zoom Set jpg defn
Barby Hill archaeology 1.kmz 1.99 1100x1110 5.0 default (high)
Barby Hill archaeology 2.kmz 23.5 773x1100 11.2 max
Barby Hill archaeology 3.kmz 13.4 883x1220 10.0 max
Barby Hill archaeology 4.kmz 17.2 846x962 10.0 max
Barby Hill archaeology 5.kmz 20.7 846x962 10.0 max
Barby Hill archaeology 6.kmz 18.1 772x822 10.0 max
Barby Hill archaeology 7.kmz 11.3 772x822 7.0 max
Barby Hill archaeology 8.kmz 9.74 778x718 7.0 max

Comments/Hints:
 The “canvas size” is the size in pixels of the working-area of QGIS; thus, if you want to

reduce the map size to a specific area – say 800x400 pixels – do this by exiting full-screen
mode in QGIS and then re-sizing the reduced QGIS window to get the required map canvas
size containing the relevant data; this helps to keep the Garmin map filesize to a minimum.

 A zoom factor of 7.0 is adequate for most tasks when working with results from a
Bartington magnetometer, as the Snuffler plots are of limited resolution in the first place.

 Check the size of the map canvas (this data, in pixels, is stated under the “Information” tab
in the GarminCustomMaps plug-in screen; then set these values in the tile size fields in the
plug-in, to ensure minimum filesize and optimum resolution.

 Always set JPG definition to “max”, only reduce it if you really need to get the filesize down.

3. Field Trial
The most relevant version of the experimental Garmin map (“Barby Hill archaeology 8.kmz”) was
loaded into the Garmin handset, and a field trial was carried out in Field 02 at Barby Hill.

Measured reference stakes were set out accurately along the field’s north border, using tapes and
pegs and based on the Barby Hill Project’s zero marker points for Field 02.

The Garmin handset and map were then used, to locate a set of specific objects for which accurate
positions are known (“door-posts” and “hearth” in a roundhouse close to the field’s north
boundary). The accuracy of the readings was assessed by measuring from the known staked
reference points and comparing with the known positions on the project master map.


