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Working with MapInfo and QGIS (formerly Quantum QGIS)
This document describes how to carry out some basic common tasks in QGIS. Some knowledge
of MapInfo is assumed; however, where relevant, explanations of MapInfo operations are given.
QGIS is open source freeware. It may be downloaded from http://www.qgis.org/en/site/, and
used without payment or obligation. The current version is 2.0.1, as of December 2013 (but it is
not compatible with Windows XP – so if you are running WinXP, you should use QGIS v1.8.0).

1.

Transferring an existing MapInfo file from MapInfo to QGIS

A MapInfo native project file can be imported directly into QGIS in a single operation – but if it is
done in this way, all the individual layers in the MapInfo file will be combined into a single layer
in QGIS, with no colour distinction, and they cannot be separated again. This is obviously
undesirable.
Therefore, to maintain the separate layers in the original MapInfo file, you must export each
layer from MapInfo separately, one at a time, and then import them one by one into QGIS.
Using this method, CLASP’s existing OS MasterMap dataset can be transferred into
QGIS, to provide a basic reference frame for any project-specific work.
Step 1: Export the layers individually from MapInfo
n Open the required table (*.TAB file) in MapInfo.
n Open a browser window (menu commands Window>New Browser Window, or just press
F2) and then select "Clasp_Topographic_2013" from the dropdown list offered.
n Use Query>Select, then build a query to select the sub-group of features that you want:
(eg all records in "Clasp_Topographic_2013" for which DescriptiveGroup = "Road Or
Track").
n Run the query – the results will be displayed in the browser as a new Table. Then save the
result, using File>Save As… and selecting the Table that you have just created – when
prompted for a name, enter the filename under which you want to save it. In the example
above, you could save it as "Clasp_Topo_Roads.TAB"
n Continue to run queries and save the resulting tables, until you have saved ALL the
DescriptiveGroup categories in the original MapInfo file. For example, in the file
"Clasp_Topographic_2013", there are 9 DescriptiveGroup categories:
Building
Inland Water
Road or Track
Path
Rail
Landform
(this has sub-categories, save each of them in turn)
General Feature
(ditto)
General Surface
(ditto)
Network or Polygon Closing Geometry
(ditto)
Step 2: Import the individual saved layers into QGIS
n Open a New Project in QGIS, and save it, e.g. as "QGIS test project"
n Now use the command Add Vector Layer to add each layer that you saved from MapInfo in
Step 1, browsing to locate each file in turn.
n Re-save the project at regular intervals.
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Adding new survey data into QGIS (and MapInfo, where relevant)

OK, you’ve loaded the OS MasterMap data into QGIS, which gives you a basic reference frame,
upon which to add your project-specific data. So, how do you add your own project data?
n Important Note: QGIS does not make copies of the raster and vector files that you load into
it – instead, QGIS remembers the location of all these files. Hence, before you start loading
any vector or raster files into QGIS, you should take the time to copy all the files that you
will want into suitable sub-folders of the folder in which you are storing your project master
file, otherwise you will probably get into trouble later on, by accidentally deleting or moving
files that are used in your project.

2.1

Placing a raster graphic file accurately into a layer in QGIS

Raster graphics can include such items as images of early maps, magnetometer plots, aerial
photographs, hand-drawn sketches and diagrams of parts of a site, etc. These are all things that
you might want to include in your QGIS project map.
How to do it:
First select and import the required graphic file, using the button Add Raster Layer and
browsing to find the file that you want. This is easy.
Now you need to get the imported graphic to display in the correct location on the map, and at
correct magnification. To solve these problems, the imported graphic must be georeferenced*.
(* In plain English, this simply means “identify some key points on your graphic,
and give them accurate OS mapping references that QGIS can understand”.)
First ensure that you have selected the required raster layer in the Layers display box. Then
there are two ways to georeference it:
n Using the menu option Raster>Georeferencer
n Using the menu option Settings>Custom CRS
The second of these methods is described in the Appendix. It uses only 2 georeference points
and it is perfectly OK – but the first method above is rather more flexible, a bit easier to use, and
potentially more accurate, as it allows you to define any number of georeference points on your
selected raster graphic. This method is described below:
n In GQIS, select the menu command Raster>Georeferencer>Georeferencer. This opens a
screen in which you must first select a graphic image by browsing to find the image file that
you want to import (Caution: ensure the image file is correctly aligned, with North at the
top, before you import it!)
n Now assign OS grid co-ordinates to selected points in the chosen graphic image, as follows:
n Select Edit>Add point, and then choose the option to use the pen tool to add a point from
the map canvas* on to the graphic image. (*assuming that you have the appropriate
MasterMap data already available and loaded into QGIS)
n Repeat this several times, adding further points. HINT: Choose points on the image that can
easily be located on the map, such as road junctions, points on buildings, field corners etc.
n When you have marked sufficient points, select from the Georeferencer sub-menu (ie the
sub-menu in the panel halfway down your screen, in which the imported graphic is still
located) the option Settings>Transformation Settings, enter a meaningful name for the
output raster file that will appear in your project when it is imported, and then just press
OK, there’s no need to fiddle with the other settings.
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n Now the raster file will appear in the correct location on the QGIS map. You can edit its
attributes – for example, adjust the transparency to (say) 50% so that other layers can be
seen through the raster image layer that you have just added.
n It is not practical to import and locate a raster file that is NOT aligned with north at the top.
This is because, unlike CorelDraw, QGIS and MapInfo do not import the image itself and
store it in the project file – they just import a reference to where the image file is located on
the computer. So, if you try to rotate the image when it is imported into MapInfo or QGIS,
these operations cause huge computing problems because the original graphic file is not
contained in the project file. Thus, you must modify the graphic file first (eg in PaintShop Pro
or PhotoShop), so it is correctly aligned NS – it's a pain, but the easiest solution.

2.2

Placing a raster graphic file accurately into a layer in MapInfo

This is broadly very similar to importing a raster graphic into QGIS as described in 2.1, so for the
sake of completeness we will summarise the procedure here:
n First obtain the GPS data for several points on your chosen graphic image, eg from Google
Earth (or from QGIS if your chosen image is already loaded into QGIS).
n You must convert any co-ordinates that you get from Google Earth, because they will be in
degrees of Lat/Long, and QGIS/MapInfo use OS grid co-ordinates, see Appendix A. There is
a co-ordinate conversion tool at http://www.bgs.ac.uk/data/webservices/convertForm.cfm
n Now open the project in MapInfo to which you want to import your graphic.
n Open File > Table, and select files of Raster Image type.
n Browse and select the chosen raster image file.
n A tick box now appears, offering a choice of Display or Register – select Register.
n You will now see a picture of the selected image file, with various editing options.
n First select the required Projection type: this will normally be:
British Co-ordinate Systems > British National Grid
n Now select 4 or more points (eg the four corners of the image) and assign the to these the
GPS co-ordinates that you have already obtained for the image.
n Then press OK, and the image will be registered and displayed

2.3

Loading OS maps into QGIS and MapInfo

OS provides free downloads of its “Street View” maps for the entire UK, including high-res maps
in TIFF raster format. These are just simple road maps with no topographic information, but they
are better than nothing and can be useful “background” maps to establish a precise base for
adding other details, once they have been imported into QGIS and georeferenced.
Alternatively, you can import scans that you have made from any OS map into QGIS (or
MapInfo), just as described in 2.1 and 2.2. (Bear in mind, however, that OS imposes copyright
limitations on its maps, and though you can use this procedure for your own research you are
not authorised to use scans of their maps in published work etc.)
n Note 1: Once a raster image map has been georeferenced in MapInfo, it can be loaded
directly into QGIS without any further need of georeferencing, since the required .TAB file
for the image file has already been created by MapInfo and it will work equally well in QGIS.
n Note 2: The reverse of this operation – ie loading into MapInfo a raster image map that has
already been georeferenced in QGIS -- does NOT work, however. This is because QGIS does
not create a *.TAB file for the georeferenced points; instead it creates a *.points file, which
MapInfo cannot read. There is no obvious reason for this lack of backward compatibility.
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Loading Excel file data into QGIS (eg a plot of finds/locations)

This must be done by adding a new “delimited text” layer. There are “how-to-do” instructions
for this online at:
n http://maps.cga.harvard.edu/qgis/wkshop/import_csv.php
n http://www.qgistutorials.com/docs/importing_spreadsheets_csv.html
Excel files must first be converted into CSV (comma-separated variable) format.

2.5

Loading data from an Excel file into MapInfo

There are two ways of doing this, and neither methods requires conversion of the data format,
the native MS Excel data format can be imported directly:
a) A complete spreadsheet or, a page or section of a spreadsheet, can be imported direct into
MapInfo via the menu options File>Open Table, then selecting File Type as "Microsoft
Excel", then selecting the desired directory and file, and then following the on-screen
prompts to select the relevant part of the chosen file (the entire spreadsheet, a selected
page, or a specified range of cells).
However, this type of import does not allow the table to be edited or modified after it has
been imported, so it is fairly restricted.
b) A better approach is to start by creating a new table, and then copying and pasting data into
it. Use the menu options File>New Table, then select "open new browser window" not
"open new mapper window"; next, add fields one by one to define the New Table Structure
(you can edit, expand and/or modify the structure at any later time via the menu options
Table>Maintenance>Table Structure); then you can simply use cut and paste to fill the new
empty table with data. In MS Excel, select the required range of cells from the source
spreadsheet (NB: do not include any header cells in your selection); now use CTRL+C to copy
your selection; then enter Mapinfo, select the new empty table that you have just created,
and use CTRL+V to paste the selected MS Excel data into the new table.
With this method of data import, the table and its data can be edited or modified after it has
been imported.
If you intend to display the imported data on a map, the imported data table must include
columns for the Easting and Northing of each line of data in the table.

2.6

Loading a *.kml1 file into QGIS (eg, as used with Google Earth)

xxx

2.7

Generating a Garmin Map File (*.kmz2) from QGIS

It is easy to use QGIS to create maps that can be downloaded and used in a standard Garmin
GPS handset. To do this, you need to be using QGIS v2.0.0 or later (which requires Windows 7
or later), and you will also need to download and install the small plug-in ‘GarminCustomMaps’
from the QGIS plug-ins official website (http://plugins.qgis.org/plugins/).

1
2

Keyhole Markup Language
A proprietary version of KML used by Garmin GPS software products
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The method for creating such maps, together with the results of an experimental assessment of
the practical accuracy and usefulness of such a method, is described in Appendix B.
The resulting maps work in any Garmin GPS device; they also work directly in Google Earth. This
method provides a simple and cheap way to find approximate locations for objects that have
already been recorded in MapInfo or QGIS – and provided high accuracy is not essential, it may
be regarded as a useful fieldwork tool.

2.8

Annotating and enhancing data in QGIS

xxx

3.

Exporting a QGIS project file back from QGIS into MapInfo

xxx
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Appendices:
A:

How to put scanned maps into QGIS: an alternative method

Typical Problem
What I have: A large TIFF covering parts of several contiguous sheets of the British OS 6 inch first
edition. It has no georeferencing, it's just a series of scans that someone has stitched together
(actually gdal_transform extracted it from a larger .ecw). I assume the projection of all this data
will be close to if not identical to the current OS projection.
What I want to achieve: The TIFF properly georeferenced so it can be used as a basis for
georeferencing various tithe maps.
Solution
The other way of georeferencing old maps also uses OS Grid co-ordinates (not grid references
and definitely not Lat/Long). If your map images are true undistorted scans you might, with luck,
be able to do this using just two points.
n Find 2 features on the map that still exist today, road junctions are good for this. Ideally,
one feature will be near (say) the bottom left corner of the map and the other will be
near the top right corner.
n You now need the OS grid co-ordinates for these 2 points. Do this by finding each
feature in Google Earth. Zoom in on a feature, note its lat/lon, then repeat for the
second feature. Then convert the lat/long co-ordinates to OS grid co-ordinates using an
online co-ordinate converter. The OS web site has one, and there are several others.
Reminder: the co-ordinates must be full 6-figure eastings and northings.
n Georeference the map using the two co-ordinates, set the georeferencer to use Helmert
and Linear, and set the Target SRS to EPSG:27700.
n On-line co-ordinate converters are a pain, you can use QGIS to do the conversions for
you. In QGIS go Settings -> Custom CRS...,
which will pop up a box like that shown in the
picture. Ignore the top half. Copy the text
shown below into the "Parameters" field:
+proj=tmerc
+lat_0=49
+lon_0=-2
+k=0.9996012717 +x_0=400000 +y_0=-100000
+ellps=airy
+datum=OSGB36
+units=m
+no_defs
n Then enter the latitude from Google Earth into
the "North" field and the longitude into the
"East" field. Then press "Calculate", which will
give the full OS eastings and northings for the
point. Ignore the commas.
In the example 471505.0083 is the easting (x)
and 175224.7406 the northing (y).
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B:

Using QGIS v2.0.1 with the ‘GarminCustomMaps’ plug-in

1.

Introduction

Trials were carried out, using QGIS v2.0.1 to create maps for direct use in a Garmin-powered
GPS handset. The aim was to evaluate the practicality of this method for use in the field.
Method:
n The geophysics results for Barby Hill (in the form of a JPG screen-grab from the CorelDraw
master-map, correctly aligned with the National Grid) were loaded into QGIS v2.0.1 and
georeferenced so as to position the image accurately w.r.t. the National Grid in QGIS.
n A number of experimental Garmin sample maps were created, using the QGIS plug-in
GarminCustomMaps, and with various different settings of the available variables.

2.

Experimental results

Filename

Size (Mb)

Set tiles

Set zoom

Set jpg defn

Barby Hill archaeology 1.kmz
Barby Hill archaeology 2.kmz
Barby Hill archaeology 3.kmz
Barby Hill archaeology 4.kmz
Barby Hill archaeology 5.kmz
Barby Hill archaeology 6.kmz
Barby Hill archaeology 7.kmz
Barby Hill archaeology 8.kmz

1.99
23.5
13.4
17.2
20.7
18.1
11.3
9.74

1100x1110
773x1100
883x1220
846x962
846x962
772x822
772x822
778x718

5.0
11.2
10.0
10.0
10.0
10.0
7.0
7.0

default (high)
max
max
max
max
max
max
max

Comments/Hints:
n The “canvas size” is the size in pixels of the working-area of QGIS; thus, if you want to
reduce the map size to a specific area – say 800x400 pixels – do this by exiting full-screen
mode in QGIS and then re-sizing the reduced QGIS window to get the required map canvas
size containing the relevant data; this helps to keep the Garmin map filesize to a minimum.
n A zoom factor of 7.0 is adequate for most tasks when working with results from a Bartington
magnetometer, because the Snuffler plots are of limited resolution in the first place.
n Check the size of the map canvas (this data, in pixels, is stated under the “Information” tab
in the GarminCustomMaps plug-in screen; then set these values in the tile size fields in the
plug-in, to ensure minimum filesize and optimum resolution.
n Always set JPG definition to “max”, only reduce it if you really need to get the filesize down.

3.

Field Trial

The most relevant version of the experimental Garmin map (“Barby Hill archaeology 8.kmz”)
was loaded into the Garmin handset, and a field trial was carried out in Field 02 at Barby Hill.
Measured reference stakes were set out accurately along the field’s north border, using tapes
and pegs and based on the Barby Hill Project’s zero marker points for Field 02.
The Garmin handset and map were then used, to locate a set of specific objects for which
accurate positions are known (“door-posts” and “hearth” in a roundhouse close to the field’s
north boundary). The accuracy of the readings was assessed by measuring from the known
staked reference points and comparing with the known positions on the project master map.
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